Friday, July 8, 2016

Hacker Rank 30 days of code Day 3: Intro to Conditional Statements

The problem:

Objective 
In this challenge, we're getting started with conditional statements. Check out the Tutorial tab for learning materials and an instructional video!
Task 
Given an integer, , perform the following conditional actions:
  • If  is odd, print Weird
  • If  is even and in the inclusive range of  to , print Not Weird
  • If  is even and in the inclusive range of  to , print Weird
  • If  is even and greater than , print Not Weird
Complete the stub code provided in your editor to print whether or not  is weird.
Input Format
A single line containing a positive integer, .
Constraints
Output Format
Print Weird if the number is weird; otherwise, print Not Weird.
Sample Input 0
3
Sample Output 0
Weird
Sample Input 1
24
Sample Output 1
Not Weird
Explanation
Sample Case 0:  
 is odd and odd numbers are weird, so we print Weird.
Sample Case 1:  
 and  is even, so it isn't weird. Thus, we print Not Weird.

My submission:
 #include <map>  
 #include <set>  
 #include <list>  
 #include <cmath>  
 #include <ctime>  
 #include <deque>  
 #include <queue>  
 #include <stack>  
 #include <string>  
 #include <bitset>  
 #include <cstdio>  
 #include <limits>  
 #include <vector>  
 #include <climits>  
 #include <cstring>  
 #include <cstdlib>  
 #include <fstream>  
 #include <numeric>  
 #include <sstream>  
 #include <iostream>  
 #include <algorithm>  
 using namespace std;  
 int main(){  
   int N;  
   cin >> N;  
   if (N%2 == 0)  
     {  
     if(N>=2&&N<=5)  
       cout<<"Not Weird";  
     else if (N>=6&&N<=20)  
       cout<<"Weird";  
     else if (N>20)  
       cout<< "Not Weird";  
     }  
   else   
     cout<<"Weird";  
   return 0;  
 }  

No comments:

Post a Comment