Friday, July 8, 2016

Hacker Rank 30 days of code Day 5: Loops

The problem:
Objective 
In this challenge, we're going to use loops to help us do some simple math. Check out the Tutorial tab to learn more.
Task 
Given an integer, , print its first  multiples. Each multiple  (where ) should be printed on a new line in the form: N x i = result.
Input Format
A single integer, .
Constraints
Output Format
Print  lines of output; each line  (where ) contains the  of  in the form: 
N x i = result.
Sample Input
2
Sample Output
2 x 1 = 2
2 x 2 = 4
2 x 3 = 6
2 x 4 = 8
2 x 5 = 10
2 x 6 = 12
2 x 7 = 14
2 x 8 = 16
2 x 9 = 18
2 x 10 = 20
My submission:

 #include <map>  
 #include <set>  
 #include <list>  
 #include <cmath>  
 #include <ctime>  
 #include <deque>  
 #include <queue>  
 #include <stack>  
 #include <string>  
 #include <bitset>  
 #include <cstdio>  
 #include <limits>  
 #include <vector>  
 #include <climits>  
 #include <cstring>  
 #include <cstdlib>  
 #include <fstream>  
 #include <numeric>  
 #include <sstream>  
 #include <iostream>  
 #include <algorithm>  
 #include <unordered_map>  
 using namespace std;  
 int main(){  
   int N;  
   cin >> N;  
   for(int i = 1; i<=10; i++){  
     printf("%d x %d = %d\n",N,i,N*i);  
   }  
   return 0;  
 }  

No comments:

Post a Comment